Mikrotik отправляем выборочно трафик через VPN

В продолжении этой статьи, в которой мы научили Mikrotik подключаться к VPN серверу по протоколу L2TP, в этой заметке рассмотрим выборочное (по списку) перенаправление исходящего трафика через VPN сервер.
В двух словах для чего это может понадобится.
Реальная история, есть прекрасный OpenSource проект архиватора 7-zip, в погоне за блокировкой Telegram местный провайдер прихлопнул и его:).
На этом примере рассмотрим, как получить доступ к 7-zip, соответственно при условии, что данный ресурс доступен из VPN сервера:)

Немного вводных данных:

  • Считаем, что VPN клиент на Mikrotik настроен и работает
  • Имя интерфейса L2TP клиента — marvins
  • Имя списка с IP адресами — rkn
  • Адрес локальной сети — 10.200.6.0/24

Суть материала — мы создадим список (Address List) ресурсов (IP адреса) под именем rkn, далее весь исходящий трафик будет просматриваться и при совпадении из списка rkn данный трафик будет помечаться маркером и при наличии этого маркера будет пересылаться через VPN соединение:)

В списке у нас будет фигурировать всего один IP адрес, для теста нам этого хватит:

/ip firewall 
address-list add list=rkn address=159.65.89.65

Либо ручками: IP—>Firewall—>Address List
Mikrotik отправляем выборочно трафик через VPN
Добавляем mangle правило, которое будет маркировать трафик:
/ip firewall mangle
add action=mark-routing chain=prerouting dst-address-list=rkn new-routing-mark=\
rkn passthrough=yes src-address=10.200.6.0/24

Или руками:) IP—>Firewall—>Mangle
Mikrotik отправляем выборочно трафик через VPN

Mikrotik отправляем выборочно трафик через VPN

Mikrotik отправляем выборочно трафик через VPN
Жмем ОК

Теперь нам осталось настроить роутинг маркированного трафика:

/ip route
add distance=1 gateway=marvins routing-mark=rkn

Ну или руками:) IP—>Routes
Mikrotik отправляем выборочно трафик через VPN

Проверяйте — должно работать:)

Mikrotik отправляем выборочно трафик через VPN
Было
Mikrotik отправляем выборочно трафик через VPN
Стало
Рейтинг
( Пока оценок нет )
Понравилась статья? Поделиться с друзьями:
Добавить комментарий

Этот сайт защищен reCAPTCHA и применяются Политика конфиденциальности и Условия обслуживания Google.

:) :D :( :o 8O :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen:
This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.